Issue
HP Probook or Elitebook Laptop is charging but is not showing external monitors while connected to docking station via USB-C.
Environment
This article applies to HP Probook and Elitebook series laptop's.
Resolution
1: Open "Device Manager", and expand the "Display adapters" field. Look to see if the "Intel(R) Iris(R) Xe Graphics" driver is listed.
- If you have an Elitebook, you may see an "Nvidia" driver shown in addition. If you see the "Nvidia driver" but don't see the Intel(R) Iris(R) Xe Graphics, continue with this guide.
- If you see the Intel(R) Iris(R) Xe Graphics already listed, you may be running into a different issue. If this guide does not fix the problem, refer to this guide - Article - Installing Drivers for HP D... (ecpowerslife.com)
2: Go to the HP website on the Laptop Drivers and Downloads page - Official HP® Laptop Drivers and Software Download
3: Click on the button labeled "Let HP Detect your product".
4: Click "OK" on the pop-up box from HP to allow the website to detect your device. If you do not see this window come up, try using a different web browser (Chrome/Edge).
- If another browser stil doesn't not work, you can open HP Support Assistant to find your Serial Number. Upon opening the application, click "Continue as guest", the look for the Serial Number under the image of a computer:
5: After the detection is done, you should see your model of computer listed. Click on the box showing your computer.
6: In box 1, select "Windows 10" as your OS. In box 2, Select "Windows 10 Version 22H2 (64-bit). Then click "Submit".
7: Click the "Detect my drivers" button. If you do not see this button, proceed to the next step.
8: Expand the "All Drivers" field, and expand the "Driver-Graphics" field. Look for the "Intel Video Driver and Control Panel" installer and download it.
9: If you have HP Support Assistant downloaded, you will see the prompt below. Go ahead and click OK. If you do not have HP Support Assistant downloaded, you can download the file without it OR go ahead and download and install HP Support assistant here - HP Support Assistant | HP® Support
10: Click "Open", and the installation will begin downloading.
- Once it is done downloading, you will be prompted to click "Install now"
11: You will receive a pop up window from HP to begin the installation. Click Next and follow the prompts (you will not need to change any of the default settings during this installer)
- Accept terms in the license agreement
- Click "Next" on the Location to Save files page. You do not need to change this location.
- Select "Update" and click "Next
- Once completed, you will be prompted to restart your computer. Use this time to save any documents you are working on before restarting.
12: Test your docking station again and see if it your monitors are showing up. If it does work, great job! You can stop here and continue on with your day! If not, you may refer to this Article - Article - Installing Drivers for HP D... (ecpowerslife.com)
Cause
Sometimes computers don't automatically get all the updates and drivers they need when MIS completes our updating steps, even though they should, this is a rare issue. We do our best to filter through and test everything before we deploy a device, but sometimes we don't catch it. Luckily these are generally easy fixes.
***If this guide didn't help you, or you notice any inconsistencies, make a comment or let us know so we can look into it and update this guide.***