Drivers: Laptop - HP Probook / Elitebook - Series G4/G5 USB-C Dock - Installing Drivers for HP Docking Station

Issue

Scenario 1: Your monitors or other devices connected to your docking station randomly stopped working, or flicker occasionally when everything was previously working fine. The dock also may not charge your laptop.

Scenario 2: You just received a new computer, but your docking station isn't working with your monitors or other devices, and/or is not charging your laptop.

Environment

HP Probook, Elitebook and other HP laptop's.

Resolution

1: Go to the HP website on the Laptop Drivers and Downloads page - Official HP® Laptop Drivers and Software Download

2: Click on the button labeled "Let HP Detect your product".

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3: Click "OK" on the pop-up box from HP to allow the website to detect your device. If you do not see this window come up, try using a different web browser (Chrome/Edge).

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4: After the detection is done, you should see your model of computer listed. Click on the box showing your computer.

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5: In box 1, select "Windows 10" as your OS. In box 2, Select "Windows 10 Version 22H2 (64-bit). Then click "Submit".

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6: Click the "Detect my drivers" button. If you do not see this button, proceed to the next step.

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7: HP will display a list of Drivers available for you to download. If you notice any drivers shown in Red as Critical, it is recommended to download and install those first, then test to see if that resolved your issue. Always restart your computer after installing each driver if the installer does not ask you to do so. 

  • If you do not see a Critical Update shown, continue to Step 11

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8: If you have HP Support Assistant downloaded, you will see the prompt below. Go ahead and click OK. If you do not have HP Support Assistant downloaded, you can download the file without it OR go ahead and download and install HP Support assistant here - HP Support Assistant | HP® Support

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9: Click "Open", and the installation will begin downloading.

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  • Once it is done downloading, you will be prompted to click "Install now"

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10: You will receive a pop up window from HP to begin the installation. Click Next and follow the prompts (you will not need to change any of the default settings during this installer)

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  • Accept terms in the license agreement
  • Click "Next" on the Location to Save files page. You do not need to change this location.
  • Select "Update" and click "NextUploaded Image (Thumbnail)
  • Once completed, you will be prompted to restart your computer. Use this time to save any documents you are working on before restarting.
  • Test your docking station again and see if it works. If it does work, great job! You can stop here and continue on with your day! If not, proceed to the next step.

11: Under the BIOS-System Firmware tab, click the "+" symbol to expand the contents and download the "HP BIOS and System Firmware" shown. (You may notice a tab with Docks-Firmware and Driver listed below which you may be thinking is the correct solution for your fix, but, just be patient and stick with us on this. This BIOS and System Firmware driver is what usually fixes this issue)

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  • If you have HP Support Assistant downloaded, you will see the prompt below. Go ahead and click OK. If you do not have HP Support Assistant downloaded, you can download the file without it OR go ahead and download and install HP Support assistant here - HP Support Assistant | HP® Support

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  • Click "Open", and the installation will begin downloading.

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  • Once it is done downloading, you will be prompted to click "Install now"
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12: You will receive a pop up window from HP to begin the installation. Click Next and follow the prompts (you will not need to change any of the default settings during this installer)

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  • Accept terms in the license agreement
  • Click "Next" on the Location to Save files page. You do not need to change this location.
  • Select "Update" and click "NextUploaded Image (Thumbnail)
  • Once completed, you will be prompted to restart your computer. Use this time to save any documents you are working on before restarting.
  • Test your docking station again and see if it works. If it does work, great job! 

 

Cause

Sometimes files become corrupted or lost from our hard drives, the part that stores all data on our computers. Unfortunately sometimes it can be core system files that are lost! This can cause strange and random issues for us. Don't you love technology!? Fortunately this is generally a quick and easy fix if you know what to do. 

If this guide didn't help you, leave us a comment and reach out to EMIS Service Desk and we can get you up and going again!

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Details

Article ID: 5747
Created
Fri 6/16/23 3:11 PM
Modified
Wed 8/9/23 12:59 PM

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