Body
Issue
Citrix Conest application only displays on one screen OR unable to click with mouse cursor.
Environment
This article applies to Citrix.
Resolution
1:Right Click Citrix workspace in your taskbar, and click “Advanced Preferences”
Click “High DPI”
3: Select “No, use the native resolution” if this is currently enabled, try selecting 1 of the other options and see if it resolves your issue.
4: Next you will need to restart Citrix. Right click Citrix in the taskbar and click "Exit". Once Citrix is closed, start Citrix again and see if it resolves the problem.
5: Again, if the option in DPI settings you selected didn't work, try another option.
Cause
This is caused by an incorrect setting in the Citrix client.